Käytössä vanha Android? Nettiselailu ja pelit lakkaavat toimimasta 2021

Käytössä vanha Android? Nettiselailu ja pelit lakkaavat toimimasta 2021
Jos käytössä on Android -puhelin tai -tabletti, joka käyttää vanhempaa Androidin versiota kuin Android 7.1.1, tammikuussa laitteesta tulee käytännössä eksoottinen paperipaino, monellakin tavalla.

Tammikuun 11. päivä, vuonna 2021 on nimittäin sikäli edessä kohtalokas hetki, että Let's Encrypt-palvelun luomat SSL-sertifikaatit lakkaavat toimimasta vanhoilla Android-laitteilla.



Valtaosa maailman verkkosivuista käyttää nykyisin salattua yhteyttä, jonka tunnistaa selaimen osoiterivillä https-etuliitteestä, vanhaan http-etuliitteeseen verrattuna. Eli tuo maaginen pieni s on lisänä osoitteessa.

Ja noin kolmasosa maailman kaikista verkkosivuista, myös AfterDawn, Puhelinvertailu ja lukemattomat muut suomalaiset sivustot, käyttävät salauksen mahdollistavan SSL-sertifikaatin luontiin Let's Encrypt-palvelua.

Valitettavasti Let's Encryptin sertifikaatti eli varmenne, on muodostettu vasta sen jälkeen, kun Android 7.1 tuli jakeluun, joten vanhemmat Android-laitteet eivät tunnista kyseistä sertifikaattia lainkaan. Tämän kiertääkseen Let's Encryptillä on ollut yhteistyösopimus toisen varmenteita myöntävän tahon kanssa, jonka ansiosta Let's Encryptin varmenteet ovat toimineet vanhojenkin laitteiden kanssa. Nyt tämä sopimus siis raukeaa ja toimiakseen oikein, pitää laitteiden tunnistaa Let's Encryptin oma varmenne.

Mitä se sitten tarkoittaa?


Käytännössä kaikki https-osoitetta käyttävät verkkosivustot, jotka käyttävät Let's Encryptin varmenteita, ilmoittavat 11.1.2021 jälkeen vanhoissa Android-laitteissa sivuston olevan vaarallinen.

Näinhän ei oikeasti ole, vaan käytössä oleva Android-laite ei vain ymmärrä sivun olevan edelleen yhtä turvallinen kuin aiemminkin.

Voiko ongelman jotenkin kiertää?


Selaimilla ongelman voi kiertää käyttämällä Firefoxin Android-versiota, joka käyttää omaa varmennelistaansa ja luottaa Let's Encryptin varmenteisiin myös maagisen päivän jälkeen.

Lisäksi sivustot ja palvelut voivat halutessaan tehdä kahden eri varmennetarjoajan kautta luodut varmenteet, jotka ovat voimassa syyskuuhun 2021 asti, mutta tuon jälkeen tuki lakkaa niillekin.



Ongelmaksi tulevat sovellukset. Käytännössä kaikki Androidin sovellukset keskustelevat netin yli: välittävät pelitietoa, hakevat käyttäjän tietoja vaikkapa Instagramin näkymään, jne. Ja tuo kaikki tapahtuu salattujen SSL-yhteyksien yli.

Eli on enemmän kuin todennäköistä, että 11.1.2021 suurin osa Androidin sovelluksista lakkaa toimimasta vanhempaa Androidia käyttävillä laitteilla.

Onneksi laitekanta on uusiutunut. Android 7.1.1 julkaistiin jo vuonna 2016, joten käytössä pitäisi olla vähintään nelisen vuotta vanha laite, jotta ongelmia ilmenee.

Oppaamme neuvoo, miten oman tabletin tai puhelimen Android-version saa selville. Jos näyttää siltä, että versio on vanhempi kuin 7.1.1, kannattaa harkita joulupukille kirjoittamista ja laitekannan päivittämistä. Avuksi tässä tulee vaikkapa Paras puhelin -osto-oppaamme.

Kirjoittaja: Petteri Pyyny @ 17. marraskuuta, 2020 14:38
Tägit
SSL Let's Encrypt Android
Mainos - kommentit mainoksen jälkeen
  • 2 kommenttia
  • Honor6A (vahvistamaton)

    Honor 6A, tuli myyntiin syksyllä 2017. Käytössä Android 7.0, eli voivoi. CustomRomeja ei tähän(kään) saa mistään.

    18.11.2020 13:14 #1

  • kane_k

    Huhujen mukaan Let's encryptin päivitetyt sertifikaatit pystyy käsipelillä lataamaan nettisivulta ja kopsaamaan rootatun puhelimeen /system/etc/security/cacerts/ kansioon. Oma puhelimeni ei ainakaan toistaiseksi ole rootattu niin en ole viitsinyt kokeilla.

    18.11.2020 17:32 #2

© 2020 AfterDawn Oy

Hosted by
Powered by UpCloud